Email Delays
Incident Report for SolarWinds Service Desk
Resolved
This incident has been resolved.
Posted Sep 21, 2020 - 09:41 EDT
Investigating
We are currently investigating reports of intermittent email delays.
Posted Sep 21, 2020 - 08:59 EDT
This incident affected: SolarWinds Service Desk [USA] (Application (North America), Email services).