Degraded performance
Incident Report for SolarWinds Service Desk
Resolved
This incident has been resolved.
Posted May 21, 2019 - 12:19 EDT
Investigating
We are currently investigating an issue that's causing slow performance within the application's interface for US environments.
Posted May 21, 2019 - 11:32 EDT
This incident affected: SolarWinds Service Desk [USA] (Application (North America)).