US Data Center - Latency in the SWSD app

Incident Report for SolarWinds Service Desk

Resolved

This issue has been resolved. Please contact us at technicalsupport@solarwinds.com if you need further assistance.
Posted 5 months ago. Dec 26, 2024 - 11:11 EST

Monitoring

The fix has been implemented, and we will keep monitoring the app's performance.
Posted 5 months ago. Dec 26, 2024 - 09:59 EST

Investigating

We are looking into a possible widespread issue with the Service Desk tool, where new incidents are not showing up on the All Incidents page right away.
Posted 5 months ago. Dec 26, 2024 - 09:34 EST
This incident affected: SolarWinds Service Desk [USA] (Application (North America)).