Unable to view incidents when selecting them to open from the "All Incidents" page

Incident Report for SolarWinds Service Desk

Resolved

This incident has been resolved.
Posted 2 years ago. May 28, 2023 - 20:27 EDT

Investigating

We are currently investigating this issue.
Posted 2 years ago. May 28, 2023 - 18:13 EDT
This incident affected: SolarWinds Service Desk [USA] (Application (North America)).