The team identified and resolved the issue that was causing APIs that took over 30 seconds to request to fail.
If you are using the PowerBI integration, you should be able to rerun your sync and the new data will appear.
If you are continuing to see issues with API timeouts or 500 errors, please open a support ticket at technicalsupport@solarwinds.com.
Posted Oct 16, 2024 - 08:32 EDT
Investigating
We are investigating an issue where API requests that take longer then 30 seconds end up with a 500 error. Right now, we are seeing any API request that takes less than 30 seconds succeed with no issues. The main component that is impacted currently is our PowerBI integration.
Note that there is no workaround for the PowerBI integration as the team is working on resolving the issue.
Posted Oct 15, 2024 - 15:59 EDT
This incident affected: SolarWinds Service Desk [EMEA] (API (EMEA)), SolarWinds Service Desk [APAC] (API (APAC)), and SolarWinds Service Desk [USA] (API).