A fix has been implemented and we are monitoring the results.
Posted 16 days ago. Mar 24, 2025 - 13:27 EDT
Investigating
We are currently investigating a potential widespread issue with the Service Desk tool, including Slow loading times, Automation rules not running as expected, email creation delays, and round-robin assignments not working as expected.
Posted 16 days ago. Mar 24, 2025 - 09:58 EDT
This incident affected: SolarWinds Service Desk [USA] (Application (North America)).