We are continuing to monitor for any further issues.
Posted 20 days ago. Mar 17, 2025 - 18:20 EDT
Monitoring
We have successfully deployed a fix to the production environment. Our team will continue to monitor the application's performance to ensure everything runs smoothly.
Posted 20 days ago. Mar 17, 2025 - 17:33 EDT
Identified
We've identified the cause of the reported issue and are still working on a fix. Thank you for your patience.
Posted 20 days ago. Mar 17, 2025 - 17:02 EDT
Investigating
We are currently experiencing significant delays with the Service Desk notifications. Our team is actively working on a fix to resolve this issue as quickly as possible. Please note that other areas of the application remain functional.