After an extended period of monitoring, SolarWinds Service Desk is now operating normally.
At this time, we consider the incident resolved. Root cause analysis (RCA) will be shared in the coming days once the investigation is complete. Should you require any additional assistance or experience any further issues, please contact us at technicalsupport@solarwinds.com.
Posted Jul 14, 2026 - 12:01 EDT
Monitoring
Our team is continuing to monitor the application closely to ensure stability. Further updates will be shared as soon as they are available.
Posted Jul 14, 2026 - 11:05 EDT
Update
The application is accessible again, and service has been restored. Our team is continuing to monitor the application closely to ensure stability. We will provide another update if any further issues are identified.
Posted Jul 14, 2026 - 10:57 EDT
Update
We are continuing to investigate this issue.
Posted Jul 14, 2026 - 10:44 EDT
Investigating
We are currently investigating an issue affecting SolarWinds Service Desk. Some users may be unable to access the application at this time.
Our team is actively working to identify the cause and restore service as quickly as possible. We will share another update as soon as more information is available.
Posted Jul 14, 2026 - 10:30 EDT
This incident affected: SolarWinds Service Desk [USA] (Application (North America)).