Potential Expiring Web Tokens Impacting API Access
Incident Report for SolarWinds Service Desk
Resolved
We have not received any new reports in eight days and found the root cause of why a small subset of users, less than 5, had their web tokens expire. The issue was related to users changing their email address, in SWSD, which caused their web token to expire. We are putting in place a check to not expire the token when the email address is changed.
Posted Jun 12, 2023 - 13:45 EDT
Monitoring
We have not received any reports of web tokens expiring in the last 5 days. We believe this to be an isolated incident but are going to monitor to ensure the issue is resolved.
Posted Jun 08, 2023 - 19:54 EDT
Update
We are still investigating what is causing a very small number of JSON Web Tokens to expire. What we have found is that this has impacted a very small set of users and the API continues to operate normally outside of this issue.

If you find that your web token has expired, please open a support ticket by emailing us at technicalsupport@solarwinds.com.
Posted Jun 02, 2023 - 07:32 EDT
Investigating
We are receiving reports of JSON web tokens expiring with no actions taken from the user. We are investigating three things.
1. Why this is happening?
2. Is it impacting all tokens?
3. Are we able to make the tokens that have expired, active again?

A current workaround is to generate a new JSON Web Token. https://documentation.solarwinds.com/en/success_center/swsd/content/completeguidetoswsd/token-authentication-for-api-integration.htm

We will update this status as we gain more information.
Posted Jun 01, 2023 - 17:11 EDT
This incident affected: SolarWinds Service Desk [USA] (API).